Menu

GD Library extension not available

  在后台文章上传封面时,遇到了这样一个错误—GD Library extension not available with this PHP installation Ubuntu Nginx。我的博客系统后台是
  1. ubuntu18.04
  2. PHP7.2 Laravel5.7
  3. MySql5.7
  自己在本地开发环境上用到了Intervention/image,但是部署代码到服务器后为考虑到开启GD扩展,导致在使用时遇到了这个错误,通过搜索引擎,找到了解决方案。简单概括就是要安装对应版本的GD库。由于是stackoverflow,打开比较慢,故在此做一个搬运分享。以下是一个基本的原文翻译。
  GD图形扩展库是一个可动态处理图片的PHP扩展。在Ubuntu系统上应该手动的去安装它:

PHP5: sudo apt-get install php5-gd
PHP7.0: sudo apt-get install php7.0-gd
PHP7.1: sudo apt-get install php7.1-gd
PHP7.2: sudo apt-get install php7.2-gd
PHP7.3: sudo apt-get install php7.3-gd

  以上就是对应Ubuntu各版本的命令操作。你可以通过以下命令验证GD扩展是否已启用。

php -i | grep -i gd

  正常的输出结果应该是这样的:

GD Support => enabled
GD headers Version => 2.1.1-dev
gd.jpeg_ignore_warning => 0 => 0
Posted In:
编程语言

暂无评论

添加评论 您的邮箱将会被妥善保存